Help and learning

We’re ready to help!

What are the system requirements for using Doodle?

We support all the latest iterations of browsers like  Safari, Google Chrome, Firefox, Edge and Opera. Older browsers may work, but we cannot provide user support for them.

For a number of reasons, security not being the least of them, you are well advised to keep your browser up to date. 

Furthermore, JavaScript must be enabled. If it is not, you can still participate in polls (in a bare-bones view), but cannot create polls. Modern websites and modern browsers rely heavily on Javascript. In order to provide the best possible user experience there is no way around using Javascript.

Was this information easy to find?

Please help us improve by rating your experience.

thumb_down
thumb_up