Help and learning

We’re ready to help!

A message is showing, saying I need to update my browser.

If you are using Firefox, please read here.

You are using an outdated browser. Probably Internet Explorer or an old version of Firefox, which are no longer supported by Doodle.

Please make sure to upgrade your browser to a newer version.
As older browsers aren't displaying Doodle polls correctly anymore, we are now redirecting users with those browser versions to a minimalist Doodle version that allows participating in polls.

Note that everybody will still be able to participate, either with the full-featured Doodle because they're using an updated browser or with the minimalist Doodle because they have an outdated browser.

To have full admin functionality and to view the poll result you need an up-to-date browser (Latest iterations of Edge ,Firefox, Google Chrome, Opera, Safari …).

We're sorry for any inconvenience and thank you for your understanding. Thanks for using Doodle!

Was this article helpful?

Please help us improve the experience by rating this article

thumb_down
thumb_up
1 out of 2 found this helpful
Return to top

Comments

0 comments

Article is closed for comments.