Help and learning

We’re ready to help!

Why are Internet Explorer 6 and 7 no longer supported?

Last Updated -

The new Doodle requires Internet Explorer 8 or above. Internet Explorer 6 and 7 are very old and insecure Browsers. We highly recommend to upgrade Internet Explorer 6 and 7 to a new version. You can download the latest Internet Explorer from here. If you are not allowed to upgrade you will be shown a very basic version of Doodle as a fallback.

Was this article helpful?

Please help us improve the experience by rating this article

You already voted, Thanks!

Thank You