Help and learning

We’re ready to help!

What are the system requirements for Doodle?

Last Updated -

All you need is a modern browser and Internet access. We support Microsoft Internet Explorer 10, Apple Safari 6, Google Chrome 25, Mozilla Firefox 19, and Opera 12. Older browsers may work, but we cannot provide user support for them. (For various reasons – security not being the least of them – you are well-advised to keep your browser up-to-date, anyway.)

Furthermore, JavaScript must be enabled. If it is not, you can still participate in polls (in a bare-bones view), but cannot create polls.

Was this article helpful?

Please help us improve the experience by rating this article

You already voted, Thanks!

Thank You