Help and learning

We’re ready to help!

A message is showing, saying I need to update my browser. But I already updated.

Last updated -

If you are using Firefox please read here.

If you are using Internet Explorer 8, 9, or 10, but Doodle thinks that you are using Internet Explorer 7, it's probably because your Internet Explorer is running in IE7 mode.

Please press the F12 key on your keyboard to confirm this and re-set the mode to what it should be.

BEFORE – with wrong IE7 mode:

IE before

AFTER – with correct mode according to your browser version:

IE after

Now you are able to access the poll with all its functionality again.

By the way: If you have to do this (changing the browser mode) over and over again, your Internet Explorer has "Compatibility View" enabled for all Web sites (as explained in Method 2 at http://support.microsoft.com/kb/968089/en), and you should consider disabling it.
See below for a screenshot for IE 9 and IE 10.


Turning off "Compatibility View" with Internet Explorer 9

Turning off "Compatibility View" with IE 9


Turning off "Compatibility View" with Internet Explorer 10

Turning off "Compatibility View" with IE 10

Was this article helpful?

Please help us improve the experience by rating this article

You already voted, Thanks!

Thank You